Программа для удаленного управления рабочим столом — Aspia NAT Remote desktop and file transfer tool.

Автор: | 22 июля, 2022

На данный момент версия 2.4.0 реализованы следующие возможности: Управление удаленным рабочим столом, Просмотр удаленного рабочего стола, Передача файлов, Системная информация, Текстовый чат ,Шифрование ,Авторизация (возможно добавление пользователей с разными правами доступа) ,Адресная книга с шифрованием и мастер-паролем, Обход NAT с подключением по ID (с использованием Aspia Router и Aspia Relay), Прямые соединения, Аудио поддержка , Запись видео, Клиент и консоль для Windows, MacOSX и Linux, Хост только для Windows, Маршрутизатор/ретранслятор для Windows и Linux https://aspia.org

root@ubuntu:/home/andrey# cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=22.04
DISTRIB_CODENAME=jammy
DISTRIB_DESCRIPTION="Ubuntu 22.04 LTS"

Установка aspia через докер контейнер https://hub.docker.com/r/paprikkafox/aspia-server

astra-linux17-docker-portainet-aspia-server

Router/Маршрутизатор

Назначение маршрутизатора: дает идентификаторы хостам и позволяет одноранговым узлам (хостам и клиентам) договориться о том, как они будут обходить
NAT. Сервер маршрутизатора должен иметь общедоступный IP-адрес. Маршрутизатор и реле могут работать только вместе. Не забывайте установить relay/релей .

Установка Router Linux:

wget https://github.com/dchapyshev/aspia/releases/download/v2.4.0/aspia-router-2.4.0-x86_64.deb
sudo apt install ./aspia-router-2.4.0-x86_64.deb
Создание безовой конфигурации Route Linux:
sudo aspia_router --create-config

root@ubuntu:/home/andrey# sudo aspia_router --create-config
Creation of initial configuration started.
Settings file path: "/etc/aspia/router.json"
Settings file does not exist yet.
Public key directory path: "/etc/aspia"
Public key directory does not exist (Success). Attempt to create...
Public key directory created successfully.
Public key file: "/etc/aspia/router.pub"
Public key does not exist yet.
Creating a user...
User has been created. Adding a user to the database...
User was successfully added to the database.
Generating encryption keys...
Private and public keys have been successfully generated.
Writing a public key to a file...
Configuration successfully created. Don't forget to change your password!
User name: admin
Password: admin
Public key file: "/etc/aspia/router.pub"

Откройте файл конфигурации и заполните поля (при необходимости; конфигурация по умолчанию не требует редактирования в большинстве случаев) Linux

/etc/aspia/router.json

Откройте файл открытого ключа и скопируйте открытый ключ. Это пригодится для настройки реле и хостов. Linux

/etc/aspia/router.pub

Запуск службы/демона aspia-router Linux

sudo systemctl enable aspia-router
sudo service aspia-router start
ss -lp | grep 8060

root@ubuntu:/home/andrey# ss -lp | grep 8060
tcp   LISTEN 0      4096                                      0.0.0.0:8060                     0.0.0.0:*    users:(("aspia_router",pid=6416,fd=8))

Relay Релей-ретранслятор

Relay ретранслятор Назначение: Пропускает трафик между узлами (хостами и клиентами) через себя. Сервер ретрансляции должен иметь общедоступный IP-адрес. Реле может быть много и их можно разместить на отдельных машинах от Маршрутизатор. Количество серверов ретрансляции может быть от одного или более. Необходимо установить хотя бы один сервер ретрансляции.
Маршрутизатор и реле могут работать только вместе.

Установка Relay

sudo apt install ./aspia-relay-2.4.0-x86_64.deb

Создание конфигурации по умолчанию

sudo aspia_relay --create-config

Откройте файл конфигурации и заполните поля Linux , 2ip.ru , myip.ru

/etc/aspia/relay.json

    "MaxPeerCount": "100",
    "PeerAddress": "192.168.1.4",
    "PeerIdleTimeout": "5",
    "PeerPort": "8070",
    "RouterAddress": "localhost",
    "RouterPort": "8060", "RouterPublicKey":"3E06034F94D9FC3805E2794C70C48E59C387D2FE4FCCAB87495AED36C7125F60"
}

Запуск службы/демона aspia-relay Linux

sudo systemctl enable aspia-relay
sudo service aspia-relay start
ss -lp | grep 8070
sudo systemctl status aspia-relay

root@ubuntu:/home/andrey# sudo ss -lp | grep 8070
tcp   LISTEN 0      4096                                      0.0.0.0:8070                     0.0.0.0:*    users:(("aspia_relay",pid=2024,fd=6))

Консоль Console

Консоль Назначение: Позволяет создавать адресные книги, добавлять в них компьютеры и группировать их. Также
позволяет управлять компьютерами и маршрутизаторами.

Установка Консоли Windows

Запустите aspia-console-2.4.0-x86.msi и следуйте инструкциям на экране.

Создайте новую адресную книгу и настройте роутер в ее свойствах.

aspia-cons

Имя пользователя по умолчанию: admin Пароль по умолчанию: admin

ВНИМАНИЕ: Не забудьте сменить пароль! Подключитесь к маршрутизатору и измените настройки по умолчанию. пароль. Вы также можете добавить дополнительных пользователей.

Для управления маршрутизатором, перейдите в меню «Инструменты -> Управление маршрутизатором».

Клиент Client

Клиент Назначение клиента: Позволяет подключаться к хостам и управлять ими.

Установка клиента Windows

Запустите aspia-client-2.4.0-x86.msi и следуйте инструкциям на экране.

aspia-client-param

Хост Host
Назначение хоста: Разрешает принимать входящие подключения от клиентов и консолей для управления компьютером на который он установлен.

Установка хоста Хост доступен только для Windows. Запустите aspia-host-2.4.0-x86.msi и следуйте инструкциям на экране.

Включение роутера в настройках

  1. Заходим в настройки (Aspia -> Настройки… -> Маршрутизатор)
  2. Включить использование маршрутизатора
  3. Напишите адрес вашего роутера (192.168.1.4)
  4. Напишите общедоступный ключ вашего маршрутизатора (cat /etc/aspia/router.pub)

Импорт и экспорт параметров

Для выполнения импорта и экспорта через графический интерфейс на вкладке «Основные» («General») в «Конфигураторе хоста Aspia» имеются кнопки «Экспорт» и «Импорт».

Для выполнения импорта и экспорта через командную строку воспользуйтесь следующими командами:

aspia_host_config —import
aspia_host_config —export

Для получения более подробной информации по параметрам командной строки, выполните команду:

aspia_host_config —help

Существует возможность автоматизировать установку и первоначальную настройку.
Для этого вы должны выполнить следующие действия:
1 Установить приложение «Хост Aspia» на одном из компьютеров
2 Выполнить настройку параметров и добавление пользователей
3 Выполнить экспорт конфигурации в файл aspia-host-config.json
4 Поместить файл aspia-host-config.json в одну директорию с установщиком
5 msiexec /i aspia-host-2.4.0-x86.msi /quiet /qn /norestart
При установке на другие компьютеры, параметры из файла будут автоматически импортированы.

Если вы настраиваете переадресацию портов на сетевом маршрутизаторе, то пример настройки для Роутер Mikrotik может пригодиться

/ip firewall nat
add action=netmap chain=dstnat comment="Aspia Relay" dst-port=8070 in-interface=WAN
protocol=tcp to-addresses=RELAY_IP to-ports=8070
add action=netmap chain=dstnat comment="Aspia Router" dst-port=8060 in-interface=WAN
protocol=tcp to-addresses=ROUTER_IP to-ports=8060
add action=dst-nat chain=dstnat comment="Aspia Relay" dst-address=EXTERNAL_IP dst-
port=8070 protocol=tcp src-address= LOCAL_NETWORK to-addresses=RELAY_IP to-ports=8070
add action=dst-nat chain=dstnat comment="Aspia Router" dst-address=EXTERNAL_IP dst-
port=8060 protocol=tcp src-address= LOCAL_NETWORK to-addresses=ROUTER_IP to-
ports=8060
add action=masquerade chain=srcnat comment="Aspia Relay" dst-address=RELAY_IP dst-
port=8070 protocol=tcp src-address=LOCAL_NETWORK
add action=masquerade chain=srcnat comment="Aspia Router" dst-address=ROUTER_IP dst-
port=8060 protocol=tcp src-address=LOCAL_NETWORK
Replace the following with your data:
ROUTER_IP - IP address of the computer on which the router is installed.
RELAY_IP - IP address of the computer on which the relay is installed.
LOCAL_NETWORK – your local network (for example 192.168.1.0/24).
EXTERNAL_IP - your external IP address
aspia-client-linux

https://rustdesk.com/ https://rmansys.ru/remote-access/ https://getscreen.ru/

Программа для удаленного управления рабочим столом — Aspia NAT Remote desktop and file transfer tool.: 1 комментарий

Добавить комментарий

Ваш адрес email не будет опубликован.

*

code